четверг, 28 декабря 2017 г.

Смена MAC адреса на роутерах MikroTik

mikrotik-смена-mac-адреса-preview

Вас настигло непонимание, как с помощью winbox изменить MAC-адрес какого-либо из интерфейсов, ведь поле не редактируется, а справа есть только кнопка “Reset MAC Address”:

mikrotik смена mac адреса 1

Отвечаю: делается это в терминале. Жмем в меню слева “New terminal” и ручками там пишем следующее:

Где ether1 – имя интерфейса, у которого вы хотите поменять MAC-адрес.

Результат выполнения команды:

mikrotik смена mac адреса 2

Если же вы захотите вернуть заводской MAC, то как раз и воспользуетесь кнопкой “Reset MAC Address”.

Подключение USB накопителя к роутеру MikroTik и расшаривание ресурсов


После прочтения данной статьи вы получите представление о том, как подключить стандартный USB накопитель к роутеру MikroTik с последующим расшариванием папки и получением доступа к содержимому по FTP.

Особенности форматирования

Файловая система роутера отличается от той, что используется на компьютере, поэтому процедура форматирования неизбежна. Чтобы не потерять ценные данные, рекомендуется заблаговременно сделать резервную копию файлов в другое место.
После подключения флешки форматирование выполняется в определенной последовательности:
  1. Заходим в меню System – Stores.
  2. Кликаем на вкладке Disks.
  3. Выбираем стандартное имя накопителя в списке — usb1.
  4. Кликаем по кнопке Format Drive.
Далее в новом окне потребуется нажать кнопку Yes.
При внушительном объеме накопителя процесс может занять несколько минут, в этом случае рекомендуется проявить терпение и подождать. По завершению процесса в колонке Status появится надпись ready, общий объем флешки фиксируется слева от надписи.

Процесс форматирования USB flash в MikroTik

В меню Files появляется новый накопитель usb1, который доступен для перетягивания файлов.

USB флешка в меню Files роутера MikroTik

Расшаривание ресурсов с помощью Samba

Для настройки сетевого доступа потребуется совершить ряд действий с сервисом SMB (Samba):
  1. Заходим в меню IP – SMB и ставим галочку напротив слова Enabled.
  2. Прописываем имя рабочей группы в графе Domain.
  3. В графе Commet проставляем имя роутера, которое будет видно в перечне компьютеров, входящих в данную рабочую группу.
  4. С помощью опции Allow Guest открывается доступ для пользователей со статусом гостя.
  5. Если остановиться на выборе значения all в графе Interfaces – доступ автоматически откроется со всех интерфейсов.

Расшаривание папки в MikroTik с помощью Samba

Как настроить FTP сервер MikroTik?

Для выполнения этой задачи потребуется выполнить приведенную ниже пошаговую инструкцию:
  1. Заходим в меню IP – Services.
  2. В открывшемся списке выбираем FTP.
  3. Кликаем на галочку синего цвета.

Настройка FTP сервера MikroTik

Подключение по FTP проверяется достаточно просто – в проводнике вводится адрес Wi-Fi роутера, после чего появится окно, в котором потребуется ввести пароль, а также имя администратора. В открывшемся списке файлов находится usb1.

Список файлов на FTP сервере MikroTik

Алгоритм создания нового пользователя:

  1. Заходим в меню System – Users и кликаем на синем плюсике.
  2. Имя пользователя прописываем в графе Name.
  3. С помощью списка Group делаем выбор в пользу нужной группы пользователей.
  4. В соответствующем поле вводится пароль, который требуется продублировать в соседней строчке.
  5. Нажимаем ОК.

Создание нового пользователя в MikroTik

Заходим в раздел Groups и открываем параметры интересующей нас рабочей группы.

Права группы в MikroTik

Если галочка ftp проставлена – смело жмем ОК.

Разрешение группе доступа по FTP в MikroTik

В адресную строку вбиваем адрес устройства, имя пользователя и установленный пароль. После осуществления входа файлы становятся доступными по FTP.

понедельник, 25 декабря 2017 г.

Как вывести и сохранить конфигурацию Микротика в текстовый файл или на консоль



Показать конфиг в терминале:
/export compact


Сохранить конфигурацию в файл:

/export compact file=myconfig


При этом конфигурация микротика сохраняется в понятном текстовом виде, вроде:

/interface bridge
add name=bridge1
/interface ethernet
set 0 comment=To-ADSL-Modem mtu=1480 name=WAN
set 1 comment=To-LAN-Switch name=LAN
set 2 master-port=LAN
set 3 master-port=LAN
set 4 master-port=LAN
и т.д.

суббота, 7 октября 2017 г.

Mozilla просит присылать образцы шума для обучения нейросети



Mozilla совместно с Xiph.org ведёт разработку нейросети RNNoise. Цель — создание алгоритма, который превзойдёт по качеству шумоподавления конкурирующие решения, обладая способностью в реальном времени работать даже на устройствах наподобие Raspberry Pi.

Такой алгоритм будет полезен, например, при организации видеоконференций и других подобных сценариях, когда важна работа в реальном времени.
Протестировать работу алгоритма можно на специально созданной странице.

Для обучения нейросети требуется много образцов шума. Подходит шум, который записан в любом месте, где возможна голосовая связь. Требуется лишь нажать кнопку записи и помолчать минуту, а также указать, в каком окружении (авто, кафе, улица, поезд, офис) был записан образец.

>>> Подробности

пятница, 24 февраля 2017 г.

Разработчики Ubuntu Kylin представили новое пользовательское окружение UKUI

Разработчики Ubuntu Kylin, официальной редакции Ubuntu Linux для китайских пользователей, представили новое окружение рабочего стола UKUI (Ubuntu Kylin User Interface), которое планируется использовать по умолчанию в одном из будущих выпусков Ubuntu Kylin вместо окружения Unity. Отмечается, что окружение UKUI уже достаточно стабильно и готово для конкуренции с проектами GNOME и MATE. Пакеты с UKUI также могут быть установлены в обычном Ubuntu (PPA) и в Debian. Исходные тексты проекта распространяются под лицензией GPLv2.


UKUI является форком рабочего стола MATE и предлагает модернизированный вариант классической организации рабочего стола, стилизованный под оформление Windows 7. Пользователю предлагается собственная реализация двухпанельного меню с отдельной секцией для выбранных приложений, встроенной системой поиска, группировкой приложений по категориям и выделением часто используемых приложений в каждой категории. Имеется возможность объединения сходных задач в одно окно с манипуляцией ими как единым целым. Изменены экран входа в систему и панель управления. Файловый менеджер Peony (форк Caja) стилизован под Windows Explorer.


В качестве причин создания форка MATE называется желание получить оформление, более дружественное для пользователей из Китая, которые привыкли к интерфейсу Windows. Для решения этой задачи потребовалось переработать такие компоненты, как меню, панель и центр управления. Многие из внесённых изменений не соответствуют архитектуре и принципам разработки MATE, что не позволяет развивать их в рамках единого проекта. Созданию форка MATE также способствовали планы по дальнейшему упрощения и унификации интерфейса и библиотек.

Устанавливаем в Ubuntu

sudo add-apt-repository ppa:ubuntukylin-members/ukui 

sudo apt update && sudo apt install ukui-desktop-environment